Firefox 2.0.0.12 and WOT

seaniesean
Posts: 15
Joined: Fri Dec 14, 2007 8:57 pm

Firefox 2.0.0.12 and WOT

Post by seaniesean » Sun Feb 10, 2008 8:30 pm

Hello, i don't know whether anyones posted this , but the new version of firefox (2.0.0.12) is incompatible with WOT. Anyone got any good solutions, besides using the previous version of firefox? Cheers.

seaniesean
Posts: 15
Joined: Fri Dec 14, 2007 8:57 pm

Oh yeah, by incompatable, i

Post by seaniesean » Sun Feb 10, 2008 8:32 pm

Oh yeah, by incompatable, i mean, it only lets me load my homepage, and won't let me navigate to other pages. Also, please don't suggest i have a firewall/router problem. I definitely, definitely do not. Sorry to double post, couldn't see an edit button.

Sami
Posts: 6987
Joined: Sat Oct 07, 2006 11:43 am

Re: 2.0.0.12

Post by Sami » Sun Feb 10, 2008 8:42 pm

Do you have blocking enabled? If you do, does disabling it fix the problem? It seems the 2.0.0.12 upgrade broke blocking somehow, we're on it...

EDIT: It looks like [url=https://www.mywot.com'http://www.mozilla.org/security/announce/2008/mfsa2008-05.html' t=_self]this security fix[/url] in 2.0.0.12 is causing the incompatibility. It has caused some [url=https://www.mywot.com'https://bugzilla.mozilla.org/show_bug.cgi?id=415367' t=_self]other extensions to break as well[/url] and according to [url=https://www.mywot.com'https://bugzilla.mozilla.org/show_bug.cgi?id=415338' t=_self]bug 415338[/url], a fix is already in Firefox's development tree.

EDIT 2: A workaround for the problem will be included in the next WOT update, which will be available in the next couple of days hopefully.

seaniesean
Posts: 15
Joined: Fri Dec 14, 2007 8:57 pm

Thanks for the reply. No,

Post by seaniesean » Mon Feb 11, 2008 4:28 pm

Thanks for the reply. No, disabling blocking doesn't work, the addon itself needs to be disabled, i'm back on the previous version of firefox now anyway, think i'll await the update. Thanks again.

Sami
Posts: 6987
Joined: Sat Oct 07, 2006 11:43 am

Re: Blocking

Post by Sami » Mon Feb 11, 2008 5:25 pm

Hi Sean,

The add-on works for us on 2.0.0.12 as long as blocking isn't enabled for any of the components. Most users seem to have upgraded their browsers already, so judging from the feedback, this doesn't look like a very widespread problem.

You could try selecting one of the preset settings (e.g. "Normal") on the Warnings page to see if it helps. Don't forget to click "Apply settings" when you're done.

If you'd like to test the new version of the add-on that works around the problem before it goes out in a day or two, please [url=https://www.mywot.com'/support/feedback' t=_self]contact us[/url] and I'll send you a copy.

Edit: This issue is fixed in [url=https://www.mywot.com'/download' t=_self]version 20080214[/url].

seaniesean
Posts: 15
Joined: Fri Dec 14, 2007 8:57 pm

Hello again. Er, the new

Post by seaniesean » Sat Feb 16, 2008 5:16 pm

Hello again. Er, the new update now prevents WOT working properly in firefox 2.0.0.11 and 2.0.0.12! The little icon says "disabled while the browser is offline". And, obviously, i am not offline. Grr! What's that about disabling blocking? For me, that's the whole point of WOT. Ah well. So, no one has it working with blocking enabled then?

Sami
Posts: 6987
Joined: Sat Oct 07, 2006 11:43 am

Offline and blocking

Post by Sami » Sat Feb 16, 2008 5:25 pm

Open about:config, type in browser.offline to the filter field, right click the appearing item in the preference list and select Reset from the pop-up menu. Firefox apparently sometimes fails to clear this preference by itself. Toggling the "Work Offline" option in the File menu a couple of times might do the trick as well.

As I explained earlier, an overzealous security fix in Firefox 2.0.0.12 broke blocking in all previous versions of the WOT add-on. However, it works again in the latest version of the add-on, so you won't have to wait for Firefox 2.0.0.13.

seaniesean
Posts: 15
Joined: Fri Dec 14, 2007 8:57 pm

Woohoo! Great trick there

Post by seaniesean » Sat Feb 16, 2008 5:29 pm

Woohoo! Great trick there Sami, everything works, blocking, the whole caboodle. Thank you very much for your help.

Jared Gray
Posts: 102
Joined: Wed Jul 04, 2007 5:14 pm

Does The New Version Fix This?

Post by Jared Gray » Sat Feb 16, 2008 5:38 pm

Hi Sami,

was just wondering if the "new" versions of WOT (with activity score) fix this issue with firefox??

Im going to test IE-Version later with my settings... .

Thanks

Sami
Posts: 6987
Joined: Sat Oct 07, 2006 11:43 am

Re: Does The New Version Fix This?

Post by Sami » Sat Feb 16, 2008 5:43 pm

If you mean the issue with blocking, then yes, the latest version fixes it.

Edit: What I mean by the latest version here is 20080214. You can check the version number from Tools / Add-ons in Firefox.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests