Forum parser BUG - URL's not encoding correctly

c۞g
Сообщения: 21225
Зарегистрирован: Пн янв 05, 2009 4:02 am

Forum parser BUG - URL's not encoding correctly

Сообщение c۞g » Пн июл 07, 2014 4:25 am

Take this URL

Код: Выделить всё

http://support.clean-mx.de/clean-mx/viruses.php?sort=firstseen%20desc&domain=atwebpages.com

paste it as text:
http://support.clean-mx.de/clean-mx/viruses.php?sort=firstseen%20desc&domain=atwebpages.com

or wrap it with the <a> tag
[url=http://support.clean-mx.de/clean-mx/viruses.php?sort=firstseen%20desc&domain=atwebpages.com t=_self]link[/url]

Notice how the parser changes the ampersand from
&domain
to
&domain


th3br41n
Сообщения: 1184
Зарегистрирован: Сб фев 25, 2012 1:45 am

RE: Forum parser BUG - URL's not encoding correctly

Сообщение th3br41n » Пн июл 07, 2014 5:04 pm

Actually, the change from &domain to &domain is correct; the real bug is that the parser converts &domain to &amp;domain (see the page source), that is clearly wrong.

donsorg
Сообщения: 4026
Зарегистрирован: Ср ноя 30, 2011 8:42 am

RE: Forum parser BUG - URL's not encoding correctly

Сообщение donsorg » Вт июл 08, 2014 8:23 am

Thanks for the bug report. Investigating the issue.

c۞g
Сообщения: 21225
Зарегистрирован: Пн янв 05, 2009 4:02 am

RE: Forum parser BUG - URL's not encoding correctly

Сообщение c۞g » Вт июл 08, 2014 9:43 am

<quote user="th3br41n">
Actually, the change from &domain to &domain is correct; the real bug is that the parser converts &domain to &amp;domain (see the page source), that is clearly wrong.
[/quote]
I coded the post that way on purpose for visual effect...
Pay attention to the provided links; mouse-over

Guest

RE: Forum parser BUG - URL's not encoding correctly

Сообщение Guest » Вт июл 08, 2014 5:21 pm

"mouse-over"
ROFL , well it seems to be a funny response to th3br41n :)

c۞g
Сообщения: 21225
Зарегистрирован: Пн янв 05, 2009 4:02 am

RE: Forum parser BUG - URL's not encoding correctly

Сообщение c۞g » Пт июл 11, 2014 9:02 am

Link test (2):
http://support.clean-mx.de/clean-mx/viruses.php?sort=firstseen%20desc&domain=atwebpages.com

It appears the parsing BUG is still present ...

NotBuyingIt
Сообщения: 6553
Зарегистрирован: Пт мар 11, 2011 6:21 pm

RE: Forum parser BUG - URL's not encoding correctly

Сообщение NotBuyingIt » Пт июл 11, 2014 7:36 pm

Work-around: Until the parsers are tweaked, either follow the guildeline about no live live links without exception or use the entity &#38; to represent the ampersand.

Код: Выделить всё

http://support.clean-mx.de/clean-mx/viruses.php?sort=firstseen%20desc<strong>&</strong><strong>#38;</strong>domain=atwebpages.com


http://support.clean-mx.de/clean-mx/viruses.php?sort=firstseen%20desc&domain=atwebpages.com

(Using the alternative entity is less desirable because even if a URL containing it works now, the identical URL may fail should the parsers be updated.)

c۞g
Сообщения: 21225
Зарегистрирован: Пн янв 05, 2009 4:02 am

RE: Forum parser BUG - URL's not encoding correctly

Сообщение c۞g » Сб июл 12, 2014 8:35 am

<quote user="notbuyingit">
(Using the alternative entity is less desirable because even if a URL containing it works now, the identical URL may fail should the parsers be updated.)[/quote]
Exactly, which is why when the parser had been working correctly and something changed to cause it to brek it should be "fixed" rather than trying to code a work-around.

Donsorg is part-time.
Timo has always been in charge of the forum and it's coding.
Timo hasn't responded to this thread from either Support (contact form) or through notification on his user board.
Maybe Timo is part-time as well?



donsorg
Сообщения: 4026
Зарегистрирован: Ср ноя 30, 2011 8:42 am

RE: Forum parser BUG - URL's not encoding correctly

Сообщение donsorg » Сб июл 12, 2014 6:32 pm

Our developer is working on this issue. It's just July in Finland – whole country is on vacation and nobody works. Streets are empty like in the movie "[url=http://www.imdb.com/title/tt0289043/ t=_self]28 Days Later[/url]". This is summer Finland :)

Guest

OT - was RE: Forum parser BUG - URL's not encoding correctly

Сообщение Guest » Сб июл 12, 2014 7:03 pm

<quote user="donsorg">
Our developer is working on this issue. It's just July in Finland – whole country is on vacation and nobody works. Streets are empty like in the movie "[url=http://www.imdb.com/title/tt0289043/ t=_self]28 Days Later[/url]". This is summer Finland :)
[/quote]


Sorry for being OT.
Does Maavoimat (Finnish Army) and Police stop working for three months as well?:-)
Sorry I could not resist.

The Italian Armed Forces cannot even go on strike

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 3 гостя