WOT Not Compatible With New Firefox

chrisadam
Posts: 4
Joined: Thu Aug 26, 2010 7:51 am

WOT Not Compatible With New Firefox

Post by chrisadam » Thu Aug 26, 2010 8:02 am

Looking at my extensions I see that Microsoft .NET Framework 1.1 is listed as "not compatible...". I read that there were issues with this but Firefox now allows it. So why would mine be greyed out and not compatible.

Also AVG Safe Search is also listed as "not compatible...". Again I know there have been issues with this, frankly I don't know if I will use it in FF but I still like to figure out why it isn't compatible. I did a reinstall/repair of AVG and it definitely added the Safe Search functionality for FF it just isn't enabled (completely greyed out). AVG has said it should be working.

To summarize when I look at extensions I have two that are listed as "not compatible" and are completely greyed out even though it seems they should be enabled.

Jazspeak
Posts: 7295
Joined: Fri Oct 17, 2008 4:20 pm

It is certainly worth...

Post by Jazspeak » Thu Aug 26, 2010 9:22 am

It is certainly worth upgrading the .NET Framework (I think that it is up to version 4). I would also recommend disabling the Java Quickstart and Java Console in FF (the browser should still be able to handle Java without these enabled).

Since you are using WOT then you can probably do without using the AVG Safe Search. I have previously found that AVG Safe Search marks many sites as safe whereas WOT more accurately rates those sites as yellow or red. However, AVG is worth having on your computer as a running antivirus, especially the Resident Shield which provides a good level of protection, but AVG is still quite a resource hog despite recent improvements.

Once you have upgraded the .NET Framework then it might be a good idea to upgrade the FF extensions and then remove any that are not compatible with the version of FF you are using. If you browse the addons in Mozilla you will see that quite a few are only for earlier versions of FF and won't work with the latest version.

Guest

.NET Framework upgrading

Post by Guest » Thu Aug 26, 2010 9:39 am

@Jazspeak
There is no upgrage option from .NET 1.1 to a newer version because they're using different cores. .NET 1.1 is outdated. With .NET 2.0 comes a new core and the Version 1.1 was supported only for compatibility reasons.
Same with .NET 2.0 and the newest version 4.0. They're using different cores also.
My suggestion is:
Simply uninstall the Framework 1.1 including the language pack.
Install the last .NET 3.5 incl. Servicepack 2. The version 3.5 is based on the 2.0 core.
Install the .NET 4.0 client profile.
Run windows update and let them install the needed fixes.


rpm022778
Posts: 15
Joined: Sun Aug 01, 2010 2:26 am

WOT & .NET Framework Assistant

Post by rpm022778 » Sun Sep 05, 2010 4:14 pm

I had a weird thing happen I updated to the newest version of WOT it had no problems but when I checked for any updates to my add-ons and it did a compatibility update to WOT why is that necessary if the add-on is supposed to be compatible with firefox already this has happened in the past also not sure if that is a problem. Also another person posted that maybe my computer couldn't handle the add-ons I have installed I only have 13 and haven't had a problem until the plugin container was introduced maybe it is something else not sure but maybe it will be fixed on the 3.7 version of firefox when it is released on the 7th hopefully. Now as for the .net framework assistant the newest version is 1.2.1 and doesn't get grayed out if u want to know where it i slocated just check your registry Hkey local machine and look for Mozilla in your list then there is a Firefox option under that it says extensions those are the one's used by other programs like JQS, or real player stuff like that. Mine was located here (C:\WINDOWS\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension\). As you can see mine shows version 3.5 maybe that is what you need to do to get it to work.

Sami
Posts: 6987
Joined: Sat Oct 07, 2006 11:43 am

Re: WOT & .NET Framework Assistant

Post by Sami » Sun Sep 05, 2010 4:30 pm

why is that necessary if the add-on is supposed to be compatible with firefox already

It means the newest supported Firefox version was updated. This happens every time the version number is bumped on the nightly builds. The add-on itself wasn't updated.

maybe it will be fixed on the 3.7 version of firefox when it is released on the 7th hopefully

It's going to be Firefox 4.0 and I don't think it's going to be released on the 7th. The next beta version [url=https://wiki.mozilla.org/Firefox/Planning/2010-09-01#Firefox_4_Beta_5 t=_self]might be coming[/url] tomorrow though.

rpm022778
Posts: 15
Joined: Sun Aug 01, 2010 2:26 am

Release Date

Post by rpm022778 » Sun Sep 05, 2010 4:39 pm

I was looking on the release dates of the next builds 4.0 is the next major update to the browser but it shows on the 7th that a scheduled maintenance update which is 3.7 is scheduled to be released on the 7th. Maybe that will fix some compatibility issues.

Sami
Posts: 6987
Joined: Sat Oct 07, 2006 11:43 am

Re: Release Date

Post by Sami » Sun Sep 05, 2010 5:36 pm

Firefox 3.7 became 4.0 a while ago, but you're right, it [url=https://wiki.mozilla.org/Firefox/Planning/2010-09-01#Firefox_3.6.9_and_Firefox_3.5.12 t=_self]looks like[/url] 3.6.9 is scheduled to be released on the 7th.

matt9529
Posts: 2
Joined: Sat Sep 25, 2010 11:31 am

I have version 3.6.10 of

Post by matt9529 » Sat Sep 25, 2010 11:31 am

I have version 3.6.10 of Firefox.
And every so often it will freeze up, normally I just exit Firefox in frustration, but this time I noticed a box came up and said the reason was that there was an un responsive script:
Script: chrome://wot/content/cache.js:162

imratingit
Posts: 48
Joined: Tue Mar 01, 2011 1:10 pm

RE: I have version 3.6.10 of

Post by imratingit » Tue Mar 01, 2011 1:10 pm

Same thing here with 3.6.13, chrome://wot/content/cache.js:162
Maybe should they [url=https://developer.mozilla.org/en/The_thread_manager t=_self]create a thread[/url] to avoid freezing Firefox.

ex_brit1941
Posts: 6
Joined: Mon Nov 17, 2014 5:55 pm

WOT Not Compatible With Firefox 52.x

Post by ex_brit1941 » Fri Mar 31, 2017 2:15 am

When are you going to get WOT digitally signed so it can install on Firefox?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests